viernes, 23 de agosto de 2013

Numeric keypad: bueno, bonito y barato para mi GNU/Linux

Desde hace tiempo quería un teclado numérico para mi portátil que facilita mucho las cosas en programas como blender, hojas de cálculo y hasta juegos pero hasta ahora los había visto por precios demasiado elevados para lo que son.
Estas vacaciones me he encontrado en un bazar este tecladito por menos de 5 euros:

La duda al comprarlo era saber si me iba a funcionar sin problemas en GNU/Linux cuando volviera a casa porque en la etiqueta del blister no indicaba nada al respecto:

Por tanto corría el riesgo de que no funcionara en GNU/Linux ¿o no?
Había un par de pistas que me daban indicios de que no iba a tener problemas:
  1. No traía drivers ni indicaba URL en la que descargárselos.
  2. No ponía que funcionara en GNU/Linux pero si que lo hacía en Mac y en Windows muy diferentes, como son 98, XP y Vista, lo que indicaba que los drivers que iba a necesidad eran muy genéricos e incluidos en todos los sistemas de serie.
Los teclados y ratones suelen usar drivers muy genéricos y cumpliéndose las anteriores circunstancias era prácticamente seguro que iba a ir como la seda.
Y efectivamente, lo he probado en ubuntu 10.04 y 12.04 así como en Debian 7 y funciona al 100%

domingo, 4 de agosto de 2013

Compilar e instalar povray 3.7 beta en ubuntu 10.04

Hace tiempo expliqué como instalar povray 3.6 que básicamente era bajarse los paquetes deb y poco más, pero ahora necesito nuevas características que sólo tiene la última 3.7 beta.


Esta versión tenemos que compilarla, para lo que debemos hacer lo siguiente:

Desinstalar povray 3.6

Para evitarnos problemas debemos desinstalar las versiones antiguas antes de poner una nueva compilada:
apt-get remove povray povray-examples povray-doc povray-includes
O si lo queremos hacer de un modo más gráfico iniciamos synaptic u otro gestor de paquetes buscamos y desinstamos todos los paquetes que empiecen por povray.

Instalar los paquetes necesarios para la compilación

En Ubuntu 10.04 lo he hecho con el siguiente comando:
sudo apt-get install libboost-dev libboost-thread-dev zlib1g-dev libpng12-dev libjpeg-dev libtiff5-dev libopenexr-dev libsdl1.2-dev

Si usáis versiones más modernas de ubuntu o debian y dicen que algunos paquetes ya no están disponibles no hay problema escribís sólo parte de su nombre antes de poner el número de versión y pulsando la tecla TAB una o dos veces escribirá la versión correcta.
También podéis usar synaptic u otro gestor de arranque y usar su buscador para instalar la versión que os ofrecen.

Descargar el código fuente y compilarlo

Lo descargamos de http://www.povray.org/beta/source/ en el apartado 'Getting the POV-Ray Unix/Linux source'

Descomprimos

bunzip2 povray-3.7.0.RC7.tar.bz2
tar xvf povray-3.7.0.RC7.tar
cd povray-3.7.0.RC7/

Compilamos

./configure COMPILED_BY="your name  "
make
sudo make install

Y ya está.

Aclaraciones y curiosidades

El proceso de compilación tarda un buen rato sobre todo si el equipo tiene sus añitos.
Si compilas en un linux de 64 bits añade --disable-io-restrictions al final de la orden ./configure